Discussion modèle:Boîte Utilisateur

Discussions actives
Autres discussions [liste]
  • Suppression
  • Neutralité
  • Droit d'auteur
  • Article de qualité
  • Bon article
  • Lumière sur
  • À faire
  • Archives

Paramétrage correct de l'accessibilité des icônes dans les BUModifier

 
eh bien .... cela donne des choses comme-ça ....
 
ou comme ça ... sur un bandeau de propositionTdQ ça détonne un peu non ?

Bonjour. Ne serait-il pas souhaitable de rajouter le paramètre LINK vide (link=) automatiquement dans toutes les images d'icônes utilisées dans les BU ? Lorsque les alternatives sont activées dans les choix d'accessibilité, un texte rouge occupant beaucoup d'espace s'affiche et c'est désagréable. Merci de rectifier si c'est possible. Archibald Tuttle (discuter) 8 novembre 2014 à 21:10 (CET)

Bonjour. Je n'ai pas compris ta question. Pourrais-tu faire une impression d'écran pour que nous comprenions ? S'il faut modifier le modèle des BU, c'est possible, mais s'il faut modifier toutes les BU ou toutes les icônes qui apparaissent dans des BU, alors il faudra dresser un Bot. Bertrouf 9 novembre 2014 à 15:45 (CET)
 
et voici un extrait de la page de vote TdQ ...

Mais certainement ... Je pense qu'un bot pourra facilement introduire partout « link= ». En revanche je pense que le paramètre « alt= » nécessite une intervention humaine. Il faut noter que le problème est souvent présent même sur d'autres modèles d'utilisation courante, comme par exemple pour voter {{pour TdQ}} sur cette page de vote (voir copie d'écran n°3). Merci beaucoup de votre attention et bonne chance pour le dressage de bots (le but final est d'enlever tout ce rouge partout). Archibald Tuttle (discuter) 9 novembre 2014 à 23:03 (CET)

Il faut faire attention à la licence : on ne peut mettre un « link= » que si l'image est dans le domaine public ou si elle est sur Wikipédia:Crédits graphiques. – Zebulon84 (discuter) 12 novembre 2014 à 13:13 (CET)
Il n'y a plus d'image non libre sur les BU. Logo d'école, d'organismes... ont toutes été remplacées (voir la PdD et un sondage de 2008). Cependant, il y a des images de wikimédia. Techniquement, est-ce que ça veut dire qu'il faut créer un deuxième modèle de BU pour les images avec « link= » ? Ou bien qu'il faut modifier une par une les BU qui ont une image éligible ? Bertrouf 14 novembre 2014 à 10:13 (CET)

Techniquement, je pense qu'il faut (1) demander à un bot de mettre le paramètre link= dans toutes les images de touts les modèles de BU existants et (2) de renseigner manuellement tous les paramètres alt= de toutes les images dans tous les modèles de BU existants. Archibald Tuttle (discuter) 14 novembre 2014 à 12:12 (CET)

Pouvoir ajouter un titreModifier

Bonjour. Est-ce qu'on pourrait ajouter un paramètre optionnel permettant d'ajouter un titre ? FDN (Question ?) 5 mai 2015 à 03:22 (CEST)

Actualisation du codeModifier

Bonjour,
J'ai mis à jour le code CSS du modèle, notamment car il utilisait des attributs obsolètes. J'ai fait quelques vérifications d'impact et ça semble ne rien changer à l'affichage, mais merci de me notifier si il y a un effet de bord indésiré qui serait passé entre les mailles de mon filet.
Wikipédiennement, Epok__ (Insultes, éloges, simples discussions : ), le 18 octobre 2019 à 10:20 (CEST)

Revenir à la page « Boîte Utilisateur ».